4.2 won't accelerate (Carb issue?)

4.2 won't accelerate (Carb issue?)

NoRCaL1980CJ7

Jeeper
Posts
2
Thanks
0
Location
Northern California
Vehicle(s)
1980 AMC Jeep CJ7 - 4.2, T-5, D300, D30, AMC20
Hello everyone,

I have a 1980 CJ7 I recently purchased with a stock 4.2 and a T-5 trans., everything else is stock as well (no lift, etc.)
the motor does have an HEI ditributer and an MC2100 carb.

So the problem is when I am trying to accelerate thru 1st, 2nd and all other gears it will begin to accelerate until i reach about 1/4 throttle and then it will fall flat on its face untill i push the pedal to the floor. The problem is especially bad on the Freeway, it has a hard time maintaining any spped over 50 mph and 5th is pretty much useless. basically it has no power whatsoever. It starts up fine, the electric choke works and once it is warmed up it idles fine. it will rev in neutral fine but not under load.

Thanks in advance for any and all help!
-Sean
 
It could be a weak fuel pump or a dirty fuel filter or a problem with the carb.
 

Jeep-CJ Donation Drive

Help support Jeep-CJ.com by making a donation.

Help support Jeep-CJ.com by making a donation.
Goal
$200.00
Earned
$210.00
This donation drive ends in
Back
Top Bottom
AdBlock Detected

I get it, I'm a Jeep owner and ad-block detectors kinda stink but ads are needed on this site. This is a CJ site, all the ads are set for autos (some times others get through.) I cannot make them just for Jeeps but I try.

Please allow ads as they help keep this site running by offsetting the costs of software and server fees.
Clicking on No Thanks will temporarily disable this message.
I've Disabled AdBlock    No Thanks