AGR steering pump

AGR steering pump

73CJ

Crazy Sr. Respected Jeeper
Posts
3,529
Thanks
8
Location
Detroit Lakes, MN
Vehicle(s)
73 CJ5 4.0 head on a 258, HEI, Holley Projection w/ 4.56, Detroit lockers Narrowed D44 front and full float D44 rear T14 w/ D20 4 wheel discs, 38.5 Boggers
Anybody running an AGR steering pump?

P%20pump.jpg
AGR Perfomance, Inc.

I've been running one with a Mile Marker 9000# hydraulic winch and cooler for well over 30 hours of hard winching - mud. Pulling others out. Now she's lost pressure and volume. I'm thinking it should last longer?

She just sat idling and pulling for 2-4 hours at a crack, so electric is not an option.

Any ideas?
 
Anybody running an AGR steering pump?

P%20pump.jpg
AGR Perfomance, Inc.

I've been running one with a Mile Marker 9000# hydraulic winch
Yes, I installed an AGR pump last summer and it's been working great for me. I also have a Mile Marker hydraulic winch.
Are you having trouble winching or steering or both?
What do you mean you have lost pressure and volume? How do you know or measure that?
 
Pressure is down because it won't pull squat with the winch, even with a snatch block.

The steering is not smooth like it was. No fluid lost. Fluid is clean. Using Royal Purple synthetic. You can see it in the reservoir with the cap open coming back in from the return line. Not as high a flow rate as it was.
 
Are these things rebuildable? (dont know a lot about them) Or do they have to be returned under warranty for rebuild...:confused:
 
Are these things rebuildable?

They want $75 to rebuild since it's out of warranty.

Just wondering if anyone else has had an AGR fail.
 
They want $75 to rebuild since it's out of warranty.

Just wondering if anyone else has had an AGR fail.

Running a Super Pump II for eight months on a '80 CJ7 304CID with 35's. The same pump ran just as you describe when my 'hand-crafted' PS lines had too many 90-degree bends in then. Once I put on new lines that fit the radiator low clearance, the pump performs perfectly at all speed ranges, even 650RPM idle.
 
It's definitely a pump failure. Works great for a long time, but now has lost pressure. Probably a a seal or rotor fail mode. :(
 
How long have you had the pump?
 
About 4 years old. She's not a DD, about 1000 miles. But it isn't racking up miles when anchored and pulling others out.
 

Jeep-CJ Donation Drive

Help support Jeep-CJ.com by making a donation.

Help support Jeep-CJ.com by making a donation.
Goal
$200.00
Earned
$110.00
This donation drive ends in
Back
Top Bottom
AdBlock Detected

I get it, I'm a Jeep owner and ad-block detectors kinda stink but ads are needed on this site. This is a CJ site, all the ads are set for autos (some times others get through.) I cannot make them just for Jeeps but I try.

Please allow ads as they help keep this site running by offsetting the costs of software and server fees.
Clicking on No Thanks will temporarily disable this message.
I've Disabled AdBlock    No Thanks