85 cj7 auto tranny issues

85 cj7 auto tranny issues

brokenj10

Jeeper
Posts
10
Thanks
0
Location
va
so i just picked up a 1985 CJ7 auto with the 4.2 i think it has the tf999. the jeep starts and runs good but when i put it in gear it just revs up like it does in park. ive checkd the transfer case and its not in neutral and still nothing. i really dont know what to do at this point.
 
did you check the fluid? how about the shift linkage? make sure when you put the jeep in gear inside the jeep, it goes into gear under the jeep
 
the fluid is good in the tranny and i took the pannel in the floor off and the shift linkage isnt tight at all but it does go into gear on the side of the transmision, but i did notice that when i put the shifter into reverse the backup lights dosnt come on.
 
so just came back from outside and with the jeep in any gear, prnd21 and the transfer case shifted down to 4x4 low with the hubs locked in it still rolls around freely. :/
 
that sounds messed up. time for an expert i think
 
lol yea i mean it seems like the tc is stuck in neutral but im not really sure were to go now with it haha but thanks for trying man
 
ok i drained the trans fluid and it looked good wasnt burnt and changed the filter, also loosend the drain plug on the d300 and nothing at all came out, so i proceeded to take the inspection plate off and hardly no fluid came out, everything inside looked ok but i noticed when i moved the shifter to 4 hi or 4 low a shaft would move on a set of gears, but the shaft on the bottom set of gears wouldnt move and was staying in the middle of the 2 gears. so im guessing it was neutral, i worked with it a little and when i moved it to 2wd it would move over the gear like it should but it was loose and would slide back halfway off the gear towards neutral. so is this my problem?
 

Jeep-CJ Donation Drive

Help support Jeep-CJ.com by making a donation.

Help support Jeep-CJ.com by making a donation.
Goal
$200.00
Earned
$210.00
This donation drive ends in
Back
Top Bottom
AdBlock Detected

I get it, I'm a Jeep owner and ad-block detectors kinda stink but ads are needed on this site. This is a CJ site, all the ads are set for autos (some times others get through.) I cannot make them just for Jeeps but I try.

Please allow ads as they help keep this site running by offsetting the costs of software and server fees.
Clicking on No Thanks will temporarily disable this message.
I've Disabled AdBlock    No Thanks