Gas gauge

Gas gauge

Swoop

Jeeper
Posts
38
Thanks
0
Location
Gulfport ms
Vehicle(s)
1984 Cj7, 258, T-4, Dana 300, Dana 30 in front and AMC 20 in rear.
Hello everybody I and new here but I have been reading a while and have learned so much from you guys Thanks I'm don't do the computer thing much so bear with me I only drive cjs so I have owned and built afew my wife say I bye them just to work on them lol maybe she is right lol owell what ever makes me happy right. OK here is what I need help with MY TEMP and gas Gauge are craze they use to go from cool to hot when I turned the key on and empty to full. the temp Gauge has always done that the gas Gauge goes where ever it won't. checked the wire in the back 12v on gas and 5v on heat I unplugged the Gauges and grounded both Gauges they go all the way up unplug them and they go down so I guess they work?? So I bought a new sender for tip and a hole sending kit for the tank installed all and now the temp Gauge does not work at all. just stays on cool the gas Gauge WORKS but not right full is full and empty is hafe. I ran a temporary wire to both Gauges still the SAME. new ground on tank SO I need help I took the motor out last weekend 4HOUR JOB GOT TO LOVE JEEPS SO EZ. REBUILT WITH GOOD CAM AND GOING TO INSTALL THIS WEEKEND BUT I NOTICED THE BODY GROUND THAT GOES TO THE BAT IS NOT HOOKED UP ITS JUST HANGING OFF THE FIRE WALL COULD THE BE IT THE FUEL TANK IS GROUNDED TO THE FRAME AND THE FRAME IS GROUNDED TO THE BLOCK SORRY ABOUT THE GRAMMER
 
Check to make sure you have 12 volts at the fuel gauge and that wire have a good connection. Also make sure the fuel gauge is grounded good.
Concentrate on the fuel gauge first. Why? because the temp gauge doesn't even get 12 volts. It relies on a regulator in the fuel gauge. So if the regulator in the fuel gauge is bad the temp gauge won't work either.
Check out these 2 links:
Basic Troubleshooting for CJ gauges

Jeep CJ Gauge & Sender Diagnostics
 
Thanks man the links related going to help. Got all my parts for my rebuild ever thing clean and ready to go. I lift the pistons in and was going to hone when I started to put it back together took the first piston out and I had broke rings, and to think I wasn't going to put rings in, I'm glad l! Decide to, I would have put a alsome top end owell I order a crank kit to day a new crank I hate waiting ever thing happens for a reason. Men when my jeep is back up me and my wife would love to come riding with you where you live is alsome. I live in gulfport ms flat thick and mud. I am not a mudder. I mean if mud is in my way then it's going down, but I'm a trial rider and they don't like us riding here :( I'll keep you posted thanks. ps I will try to get some pic of my brat for you guys. Blue skys



.
 
Last edited:
I saw you have broken rings.. If you have a ridge on the cylinder when you push the rings outthey will break. Also I would run a 8-10 gauge wire from the battery to the fire wall then the frame and run it all the way back to the rear of the frame. I leave some stainless bolts though some soldered on ring terminals to use a ground points. The to jeeps Ive done this on have worked so much better. lights, gauges and motor. I also one a heavier wire and stud to the grill and rewire the head lights with 12ga and dedicated head light relays. The elecetrical systems on the CJ's is :dung:.
 
Well got my motor back together I just neen to clean up the intake I have a holly 2b and the jeep linkage sucks think I'll fab a plate that bolts to the to screws that hold down the carburetor bend the corners up cut a square hole so the throttle cable will clip in and Walla no more jeep linkage junk. should have the motor back in Xmas and then back to the Gauges. Well gas and temp Gauges the diagram is going the be a big help it is truly step by step and very ez to understand. I just put 3000 in the interior and then my motor just gave up it always had a tap and I have driven them like that for years then the distributor gear took a poop and took the rest with it. Flat Top pistons good strong comp cam headers and a 2b 500 holly should have a lot more power. I will keep you guys updated and merry Christmas and all the trials be conquered (blue skies)
 
Ya the rings may have broken when I took the pistons out I did not think of that. Before I took the motor down I checked 95 on all. it was low but all even. so you are probably right. I have not built a motor in 15 years just 350 Engine never a 6 it was cool I like the 258 I have to say they are a beast and they don't like engine stands lol the cam bearing go me though I didn't know there at different sizes but I got it. any tip on getting the trans and engine together would be a big help I found a pilot bearing instead of a bushing some body told me that the bearing is much better but harder to mate the trans to the motor marry Xmas and blue skies
 
Well I got my motor back in it wasn't as bad as I thought it was going to be so tomorrow I will hook everything up I just hope it runs as good as it looks like I said I haven't built a motor in a long time
 
:confused:
Whoa! I gotta admit I'm having a hard time following this thread.
You say your gas gauge isn't working.

Jimbo says:
I saw you have broken rings.. If you have a ridge on the cylinder when you push the rings out
Not sure how he got to that.

You rebuilt the motor.
Now that your cylinders have new rings does your gas gauge work?
 
:confused:
Whoa! I gotta admit I'm having a hard time following this thread.
You say your gas gauge isn't working.

Jimbo says:

Not sure how he got to that.

You rebuilt the motor.
Now that your cylinders have new rings does your gas gauge work?

:confused: :laugh:
 
OK guys sorry for jumping around but when I started this thread it was just the gas Gauge but the next day the gear on my distributor went out and took my cam with it she was a old girl anyway. I guess I'm supposed to start new threads when something new comes up?? I just started a new one about fender flares and cutting my fenders but it's on there twice and I do not no how to delete one of them?? And I do not no how to put my pic on my post?? So I'm learning thanks for the sarcasm it always helps lol
 
I lived in Biloxi for 40years. I know all those mud riding spots down there. Alot of my friends do menge ave now. Good luck on your jeep
 

Jeep-CJ Donation Drive

Help support Jeep-CJ.com by making a donation.

Help support Jeep-CJ.com by making a donation.
Goal
$200.00
Earned
$110.00
This donation drive ends in
Back
Top Bottom
AdBlock Detected

I get it, I'm a Jeep owner and ad-block detectors kinda stink but ads are needed on this site. This is a CJ site, all the ads are set for autos (some times others get through.) I cannot make them just for Jeeps but I try.

Please allow ads as they help keep this site running by offsetting the costs of software and server fees.
Clicking on No Thanks will temporarily disable this message.
I've Disabled AdBlock    No Thanks