TBI no fuel

TBI no fuel

Old Dog

Always Off-Roading Jeeper
Posts
13,886
Thanks
5
Location
Stonelick Lake, Ohio
Vehicle(s)
83 CJ7 350 tbi, TH350, D300 twin sticked & clocked, narrowed Chief D44 Eaton Elocker & Moser shafts, Explorer 8.8 Detroit locker, 410's, RE 4.5" spring lift 1" body lift, 35" Claws, cage tied to frame, Corbeau baja seats, HD tie rod and draglink, u-bolts flipped, custom skid plate and sliders, Warn 9.5ti winch with Amsteel synthetic line
I was driving down the raod friday when my jeep ran out of gas (full tank).
I have fuel going to the tbi unit but no fuel comming out of the injectors :confused:
We just got home from our trip so I haven't had a chance to check it out yet. But if anyone has any ideas I would love to hear them.:chug:
 
Clog before the injector?
Do they do anything, or make a sound?
Plug/wire going to injectors loose?
Fuel pump, mech. or elec.? check your fuel pump relay, power and ground at the fuel pump connector
Fuses?
Try starting with the TPS unplugged.
 
Last edited:
Clog before the injector?
Do they do anything, or make a sound?
Plug/wire going to injectors loose?
Fuel pump, mech. or elec.?
Fuses?

1) ?
2) when you turn the key they kinda sound like they open.
3) checked, ok
4) elect., working. (took line off at tbi and had gas comming out when pump came on. Didn't have press gauge though)
5) all the ones I know of are good.

This was done on the side of the road and in the motel parking lot. As I said above I haven't checked it out at home yet. It's raining and I really don't feel it today.
 
These are pretty simple setups, I usually check the engine compartment, then the fuel pump, lines, etc. And last the ECU, I believe the purple and white or white and purple is the one for the injectors, if i remember right you can ground it at the ECU and get the injectors to pulse.
Could be the TPS, there's also a flood clear mode on some ECU's it might be stuck in that mode, also the PROM in the ECU coulda crapped out.

If it is the prom you can get them from autozone I believe it's the same as howells.
 
Brock thanks all good ideas.
Someone in the parking lot also said to check the MAP.
I was just reading through the trouble shooting from howell and they mention it could be a bad tach conection.
Lots of things to check if I ever get motivated. Did I mention I hate elect. problems:D
Any other ideas let me know.:chug:
 
You shouldve waited till your CJ7 wasnt rig of the month anymore to post this!! :laugh: Of course youd have probably had to wait till X-mas for that to happen. :laugh: Cj you didnt find that Ban button yet did you? :)
 
You shouldve waited till your CJ7 wasnt rig of the month anymore to post this!! :laugh: Of course youd have probably had to wait till X-mas for that to happen. :laugh: Cj you didnt find that Ban button yet did you? :)


Yea don't it figure, dam thing hasn't let me down in 5 years and it picks now.
Maybe it thinks it's to good for me now.:laugh:
 
I'll assume the fuel filter is in line, So I can't really think of anything that Brock hasn't mentioned. But if you say it is getting fuel to the TBI unit then my bet would be clogged (trash) injector. I'll back down fro the elect part and leave that to the pros in that dept.
 
Ok guys give me the stupid stamp. I didn't follow through on basic trouble shooting ie. "do you have fuel and spark". I had no fuel so I stoped there.
I started checking it when I got home from work and found I had no spark, pulled a ignition module out of an old HEI sitting in the corner, stuck it in hit the key and it fired right up.:eek:
For $30 and 15 min. of time I could have been wheeling sat.:mad:
 
:poke: It happens to the best of us, just some more than others :D

:beer: You'll make up for the wheelin' next time! :)
 
lol, I've been drive'n carbs for so long, and my efi vehicles have ran so well, I forgot the ECM has to see a spark signal to tell the injectors to work.:)
 
lol, I've been drive'n carbs for so long, and my efi vehicles have ran so well, I forgot the ECM has to see a spark signal to tell the injectors to work.:)
I can't wait to get mine to the troubleshooting point!
I have to send mine to Howell to have it reprogrammed for the 360. Do they have a TBI that is made for a 4 BBL, or just a spacer? I have a Edelbrock Performer intake to put it on.
 
^^^ The howell I have takes the chevy 5.7 2 barrel TBI unit. They have a spacer to convert it to a 4 barrel manifold. I also have an edelrbrock.
It's been on mine for 2 years now, waaay better than a carb.:driving:
 

Jeep-CJ Donation Drive

Help support Jeep-CJ.com by making a donation.

Help support Jeep-CJ.com by making a donation.
Goal
$200.00
Earned
$110.00
This donation drive ends in
Back
Top Bottom
AdBlock Detected

I get it, I'm a Jeep owner and ad-block detectors kinda stink but ads are needed on this site. This is a CJ site, all the ads are set for autos (some times others get through.) I cannot make them just for Jeeps but I try.

Please allow ads as they help keep this site running by offsetting the costs of software and server fees.
Clicking on No Thanks will temporarily disable this message.
I've Disabled AdBlock    No Thanks